Requisiti hardware e software

Sar-At è un software sviluppato in linguaggio PHP e fornito ai clienti in versione interpretata o compilata, a seconda delle opzioni prescelte. Sar-At richiede la presenza del motore PHP versione 4.3.8 o superiore per il funzionamento. L'uso di alfabeti diversi dal latino richiede una libreria qualsiasi tra Iconv e MB_Strings (Sar-At 7 si configura automaticamente per usare quel che trova). La versione 5 di PHP è pienamente supportata, ma il suo uso non comporta benefici rispetto alla versione 4.

Sar-At è supportato da Accomazzi.net su server Unix, Mac OS X Server o Windows server (NT, 2000 e 2003). Accomazzi.net attualmente utilizza e supporta i sistemi operativi Linux Debian, Linux Suse, Linux RedHat e Mac OS X Server per i calcolatori che ospitano in hosting i siti basati su Sar-At. Accomazzi.net tuttavia si riserva il diritto di sostituire o affiancare altre soluzioni a quelle citate.

Sar-At si appoggia ad Apache come sistema di web server(per spedire le pagine a destinazione attraverso il protocollo http o https). Accomazzi.net ha anche testato Sar-At sotto Microsoft Internet Information Server ed è in grado di supportarlo su richiesta, ma non lo consiglia. Contattate Accomazzi.net se l'uso di IIS con Sar-At è per voi una priorità.

Il Sar-At utilizza un motore di base dati SQL "SQL " per memorizzare i testi editabili e le informazioni di servizio.

Accomazzi.net certifica Sar-At 7 per l'uso con MySQL versioni 4.0, 4.1 e 5.0 (la versione 7 si auto-configura per pilotare il database secondo le interfacce più adatte alla versione incontrata). Il processo di certificazione per altri motori di base dati può venire richiesto e concordato dai clienti.